Advertisement
Replied to Jonathan Bélanger's post on October 6th, 2017

Hi 

I have an Epp 5430R with power coming into the main board but nothing happen ( no display nothing ). someone have a solution to diagnose the board ?

avatar: medphysteo
medphysteo
287 posts
Replied to Jonathan Bélanger's post on October 10th, 2017

Are there fuses of any kind on the converter? Is there AC at the bridge rectifier but no DC out? There may be a 12V or other test point on the board, anything there? (I'm going off the 5424 board so it may be different) 

Was it ok until someone turned it off or unplugged it, and now it won't turn on? Some of the other guys have had similar problems with other Eppendorfs, and have found the problem to be faulty electrolytic capacitors. See wbeaty's posts in the power-related questions under the 5415R.

 

avatar: Augusto
Augusto
3 posts
Replied to Jonathan Bélanger's post on October 21st, 2017

Hello

 

Please check the stand by pcb ( a small pcb locate under the cover close to the power switch )

Regards

avatar: manzer
manzer
6 posts
Replied to Augusto's post on March 29th, 2019

Anyone have any follow up for this. Eppendorf says to replace the front panel for $913. Looking for something that is less of a shotgun approach. 

 

Thanks,

Kyle

avatar: manzer
manzer
6 posts
Replied to manzer's post on May 10th, 2019

I have some follow up. Eppendorf tech support said replace the front panel because the display isn't working to the tune of $900. That is not the fix I found. I found a bad inrush current limiter. Order an SG308 from mouser for $1.33, back in business.