Advertisement
avatar: RoboWill
RoboWill
19 posts
Replied to RoboWill's post on February 9th, 2018

Hello,

My Avanti J20 is giving a C5 and an S7 error but theres no information in the manual. Does anyone know what these errors are? Thank you for your help.

avatar: dpkleessr
dpkleessr
899 posts
Replied to RoboWill's post on February 9th, 2018

The S7 is a system diagnostic that requires a complete reinitialization of the centrifuge.  Those instructions can be found in the database.  I'm not sure why you would be getting a C5 diagnostic on a J20 model when it is only applicable to a J30I model.

Don

avatar: RoboWill
RoboWill
19 posts
Replied to dpkleessr's post on February 13th, 2018

Apologies, I neglected to mention it is a J 20 XP. Clearing the errors got rid of the S7 error but I still have the C5 error.

Will

avatar: dpkleessr
dpkleessr
899 posts
Replied to RoboWill's post on February 13th, 2018

Clearing the S7 is only part of the issue.  You must either enter ALL of the values that I listed in the database manually or enter some of them manually and let the centrifuge calculate the windage and inertia variables.  Again, the C5 diagnostic was really only relevant to an "I" series Avanti which you do not have so I am not really sure where that is coming from.  I am not sure from your post if you actually have reinitialized your centrifuge or not.  If you haven't then please do that first and then retry running the centrifuge normally.  If you have reinitialized the centrifuge and are still getting that error then I am really not sure what to look at next but I will try to touch base with one of my old colleagues to see if he has any input on this problem.

Don

avatar: RoboWill
RoboWill
19 posts
Replied to dpkleessr's post on February 14th, 2018

I have reinitialized the centrifuge entering the info on the maintenance sheet. The error persists. We have changed out the large board on the swing out door with an updated one from beckman, if that is a possible cause of the C5 error.

 

Will

avatar: dpkleessr
dpkleessr
899 posts
Replied to RoboWill's post on February 14th, 2018

Will, The board you swapped out is the inverter assembly and that is strictly for controlling the drive motor so that would have no impact upon resolving your problem.  All of the documentation that I have for a C5 diagnostic says that it is only related to the Avanti J30I series of centrifuge that has both a temperature probe in the bottom of the chamber and a radiometer assembly.  Sorry to say it but I am at a loss as to how you are getting this diagnostic.  At this point, you probably need a service engineer to look at the problem.

Don