Advertisement
Hettich Centrifuges
Hettich Centrifuges
avatar:

posts
Replied to 's post on August 9th, 2012

Getting error "main contactor failure" after a powercut. How do I fix it myself? It says in the manual it could be that the main fuse not available...what and where is this fuse? I am going to start opening up panels if I don't hear anything! Thermo service is not an option until i know it's not just a fuse. 

 

avatar: Jackie Quinn
Jackie Quinn
6 posts
Replied to 's post on August 16th, 2012

Hi,

I recommend you contact our Technical Support team at 866-984-3766 in North America. If you are located in another region of the world, please use the ‘Contact Us’ link on the thermoscientific.com homepage and select your country and product line to find the correct telephone number (or submit a request for help). Kindly retrieve the serial number of the unit prior to contact so that the team can verify the exact model and age of the unit.  
 
I hope this information helps,

Jackie Quinn
Laboratory Equipment
Thermo Fisher Scientific
jacqueline.quinn@thermofisher.com

Follow @ www.twitter.com/servingscience
Register @ www.thermoscientific.com/servingscience


 

avatar:

posts
Replied to Jackie Quinn's post on August 16th, 2012

Yes, if I had a blank cheque i would do that! First, I would like to ensure it's not just a fuse, otherwise I'll have paid for a call-out and an hour of labour for hardly anything.

avatar: nanacho
nanacho
4 posts
Replied to 's post on April 15th, 2013

Yo tengo el mismo problema  si pudiste reparar el daño te agradeseria mucho tu ayuda :)

Translation via Google Translate

"I have the same problem if you could repair the damage would greatly appreciate your help :)"

avatar:

posts
Replied to nanacho's post on May 23rd, 2013

It is fixed now..required a new PCB costing £2000!

avatar: nanacho
nanacho
4 posts
Replied to 's post on May 23rd, 2013

jejej ya lo resolvi fue solo las resitencias de potencia las 33 omios y el igbt que se relasiona con el modulo de frecuencia eso fue todo quedo como nueva ;)

avatar:

posts
Replied to nanacho's post on May 23rd, 2013

Were these on the main PCB?  Whereabouts?  I still have the old PCB...i could'nt see the fault with it.

avatar: nanacho
nanacho
4 posts
Replied to 's post on May 23rd, 2013

si exactamente el problema es el pcb

ay 2 resitencias de potencia en paralelo de 33 omios debes cambiar esas

y ahy un IGBT en pla pcb que comunica el modulo de RF aunque parece estar bien debes cambiarlo

y eso es todo  suerte :)