Discussion Category:  PCR / Thermal Cyclers

Tsensor Error

This is a 5332.

Eppendorf tech support says the block needs to be replaced, $1520 part with a complicated calibration. Then tried to sell an extended warranty. Is there a less expensive fix?

These folks are never helpful to outside service.

Thanks to all

davidkain

Asked by

davidkain
Report this Post

27 Replies

avatar placemarkReply by
Bodasafa

HI, this may be late but i may be able to help. Do you have a contact email?

Report this Post
avatar placemarkReply by
dkg

dear bodasafa,

 

i also hv 5333 with tsensor 1 error. we suspect its peltier defective. if u hv different solution pls let us know.

dkgupta

tekutron@gmail.com

Report this Post
avatar placemarkReply by
curvin444

Hi, could you help by a "TSensor0Error"? We run a 5331.

Report this Post
avatar placemarkReply by
service3683

There is basically no fix to the thermoblock itself. Someone told me once that if you get to replace the peltier cell element you could fix it. I've never tried myself but if you can... do it!.

Report this Post
avatar placemarkReply by
Bodasafa

The T sensor error is a failed sensor in the block. The sensor can be replaced, the unit can be calibrated, I have done it several times. It is not the easiest job but it can be done.

Report this Post
avatar placemarkReply by
service3683

What sensors did you replace?.

Report this Post
avatar placemarkReply by
Bodasafa

When you get a "TSENSORxxERROR" the xx wil give a number 

0=Left thermoblock sensor

1=Middle thermoblock sensor

2=Right thermoblock sensor

3=Lid sensor

4=thermoblock cooler

You can also check the sensor by going into the service software, the defective sensor will usually give --- instead of a temperature. The sensor are located in the back of the block, sealed in with "silicon?" they are type SMT-160 3 wire thermistors. If I remember correctly a red, green and gold wire. Let me know your email for further info.

Report this Post
avatar placemarkReply by
rbwalter

Bodasafa,

I'd be very interested in any info you have to replace the thermistors.  My e-mail address is rbwalter-at-indiana-dot-edu.

Thanks.

Report this Post
avatar placemarkReply by
Haratianfar

Hi I'm having the same problem Please help me

Hamid.Haratianfar@yahoo.com

Report this Post
avatar placemarkReply by
Douglasc

Hi,

 

We have a tsensor 1 error which I was going to attempt to repair. I was wondering if you have any details on the sensor replacement and calibration.

 

Thanks

Report this Post

Page 1 of 3