Discussion Category:  Freezers

Temperature recovery or registry problem

We have a Uxf that is working mad. I mean: we open it one day and ir doesn´t recover the temperature. After 24h the display shows -66ºC (it is set in -85ºC) but we have a probe wtth data loger that said the temperature inside the freezer is about -90ºC. Our maintenance people check the compressor parameters and evarything look fine. Also we test our data logger probe and it is working fine. ¿Any idea?

avatar placemark

Asked by

ICG
Report this Post

5 Replies

avatar placemarkReply by
ICG
We contact SAT technician by phone. He suggested a complete reset (empty the freezer, turn it off and disconnect) and after that turn it on and keep an eye on it. For the moment seems this works, it is been working properly since then (two months ago)
Report this Post
avatar placemarkReply by
ICG
We contact SAT technician by phone. He suggested a complete reset (empty the freezer, turn it off and disconnect) and after that turn it on and keep an eye on it. For the moment seems this works, it is been working properly since then (two months ago)
Report this Post
avatar placemarkReply by
Questfixa

What did SAT find with the door probe?

Did they replace it of repair it?

I have a similar condition with my UXF40086A

Report this Post
avatar placemarkReply by
ICG
Thank you. We did that, we installed an external probe with data logger and obtained bizarre data. Our probe shows -90 but the freezer shows -67 and a warning because it is unable to raise the temperature set. Other time we saw that it takes about to 48h recover set temperature after open the door. We suspect there os a problem in the freezer probe or with the controller. We have contacted SAT and said it sounds extrange, they suggest shut down, reboot the machine and see what happend.
Report this Post
avatar placemarkReply by
Natxo
There is a possibility that the control probe is blocked by frost or some material. This means that the compressors are running, so your data logger indicates -90ºC.
A test to be done is to place a PT 100 simulator in place of the probe and verify the reading on the display

 

Report this Post

Page 1 of 1