Discussion Category:  Centrifuge

Won't accept rpm setpoint, just continues to flash

We have an older J6 high speed centrifuge and now it will not accept the rpm setpoint we've ran for years. We select the rpm function, input 2500 rpm and press enter but it will not advance past this function, the rpm value just continues to flash like it's waiting for us to press the enter button although we've already pressed the enter button. Tried cycling power but that didn't help, checked the position of the key also. Thanks.
avatar placemark

Asked by

tom.gates6815
Report this Post

1 Reply

avatar placemarkReply by
dpkleessr

Tom, have you tried using the hold mode of the timer as a opposed to the timed run?  Those old timers do eventually wear out and cause a no start condition.  Also, when I retired back in 2012 the timers had become almost impossible to get unless someone else had come up with a source.  That is the first place I would start and if that doesn't help then get back to me and I'll dig out my old manual to help.

Don

Report this Post

Page 1 of 1