Discussion Category:  Centrifuge

eppendorf 5810R board diagnostics

Error 6 has numerous causes, this unit was working until moved, now it's all error 6. Temp control works fine. Does anybody know if the service manual is worth the $$? I don't want to replace the freq conv bd if I can see a work around. I have several other svc manuals for eppendorf, but the tech support folks are so unhelpful, that I may just recommend replacing unit with another more servicable brand.
avatar placemark

Asked by

AnonymousUser
Report this Post

56 Replies

SaharaSimbaReply by
SaharaSimba

Board repair services are available for the Eppendorf centrifuges.  If you are interested visit www.saharasimba.com

Report this Post
avatar placemarkReply by
GSPell

If you get an error 6 at the beginning of a run when you push start, try replacing capacitor C11 (100µF / 35V) near the heat sink'd driver transistor on the main board. (It's a common fix on other Eppendorfs, too; I think the eletrolytic juice dries out in them over the years.)

If you get an error 6 at the end of a run when you push stop, look at the braking resistor(s). A model 5424 that I worked on had an error 6. What looked like a fused jumper bar had popped on the brake resistor. Soldered it back and it worked fine.

Report this Post
avatar placemarkReply by
sarwan

Check to make sure the lid is not bent. Sometimes the users accidently jams item in between the lid and the frame. If the motor is latches while somthing is jammed in between, it will bend the lid frame. Hence this will create unneccesory loan on the motor because of the bent lid and cause the issue. This was the fault I found. Replacing the lid or identifying and straightening the lid may fix the fault.

good luck.

Cheers,
Sarwan

Report this Post
avatar placemarkReply by
sarwan

Check to make sure the lid is not bent. Sometimes the users accidently jams item in between the lid and the frame. If the motor is latches while somthing is jammed in between, it will bend the lid frame. Hence this will create unneccesory loan on the motor because of the bent lid and cause the issue. This was the fault I found. Replacing the lid or identifying and straightening the lid may fix the fault.

good luck.

Cheers,
Sarwan

Report this Post
SaharaSimbaReply by
SaharaSimba
Over current or over temp errors. Please visit Sahara Simba Electronics... we help with board repairs and testing
Report this Post
avatar placemarkReply by
josamogo
Hello friends I have the same problem, who can help us?   the probema that will not open the lid with the button   Thank you
Report this Post
avatar placemarkReply by
josamogo
Hello friends I have the same problem, who can help us? Thank you
Report this Post
avatar placemarkReply by
josamogo

Cita sarwan

Hola chicos

Tengo una falla con esta centrífuga con el problema de bloqueo de la tapa. Cuando se intenta cerrar la tapa superior, el motor intenta cerrar la tapa, pero se detiene a la mitad. Después de algunos intentos, se cierra, pero no se abre la tapa cuando se presiona el botón. Se reemplazó el motor de bloqueo de la tapa y los microinterruptores de la tapa pero la falla continúa. Se vigila la tensión del motor. El motor funciona sin carga.

¿Alguna sugerencia sobre qué podría estar causando el corte del voltaje del motor?

También sería útil el enlace al manual de servicio.

 

Gracias

Sarwan

 

Report this Post
avatar placemarkReply by
josamogo
Hello friends I have the same problem, who can help us? Thank you
Report this Post
avatar placemarkReply by
rafael_ch
Hello all. I urgently need the eppendorf 5810R service manual. Could someone send me to my email? I will be very grateful. greetings rafal.popiel@bluewin.ch
Report this Post

Page 1 of 6